Hazeron Forums

Full Version: Game crashes at load in
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3
For one character out of 5.

Malcanis: JWZX

Character actually does load but the game shuts down as soon as the environment tries to load as well.

*edit*
Grizzic: AFBJB

I was curious as to whether this was system wide or just planetary, or maybe just the character, so as a test I berthed this character into the others ship. This one is now stuck as well so I guess that makes it a system wide thing.
I can teleport to both avatars without issue.

Is this an issue on the same computer that can't show the graphical star map?
Reference: (Bug report) Star Map Gone (mostly)
Cause then it still sounds like you have a hardware/driver issue or something. It could be your graphics card and its drivers doesn't support the needed OpenGL?

Best suggestion I have right now is to make sure your drivers are up-to-date again.

My only workaround would be another computer, or use Hazeron Commander to berth-a-port/teleport them away from whatever your client/computer can't handle.
Or may be clear cache and try again?
This is a brand new PC, but I cleared the cache anyway ..no change.

OpenGL version is: 4.6.0 NVIDIA 451.67

Driver version is: 451.67 - 7/5/2020, version 90.4.76.40.cd

I've spent the last hour double and triple checking that this is correct. I even dl'd the winzip viewer to help with that and installed the latest version of OpenGL just in case. Still no change.

I find it strange though is that my other 3 characters work fine everywhere else. Even Grizzic worked until I berthed him to that system. The fact that Dean could berth in and out with no issues should tell me that the issue is mine, but then it's still only that system, which wouldn't be me. Does that mean there's some sort of cross client/server issue here?

Thank you both ..this help is very much appreciated.
(08-09-2020, 12:29 PM)Greydog Wrote: [ -> ]I find it strange though is that my other 3 characters work fine everywhere else. Even Grizzic worked until I berthed him to that system. The fact that Dean could berth in and out with no issues should tell me that the issue is mine, but then it's still only that system, which wouldn't be me. Does that mean there's some sort of cross client/server issue here?

Unless you have more than one ringworld, it could be because they are both on a ringworld.
Grizzic's ship is out of fuel and laying in the middle of the city, so if it is related specifically to your computer loading into a ringworld city, it could be why.
Yes that very well could be Dean as that is the only location I am having this issue. I am at a loss as to what to do.

I did learn how to go into the event viewer and get the crash log though.


Code:
Description:
Faulting application name: Shores of Hazeron.exe, version: 6.0.0.0, time stamp: 0x5f35d903
Faulting module name: ucrtbase.dll, version: 10.0.19041.423, time stamp: 0xaba7b35d
Exception code: 0xc0000409
Fault offset: 0x0009eddb
Faulting process id: 0x2858
Faulting application start time: 0x01d672fbf888f413
Faulting application path: C:\Users\frazb\Shores of Hazeron\Programs\Shores of Hazeron.exe
Faulting module path: C:\windows\System32\ucrtbase.dll
 I have no clue what any of that means ..maybe one of you do.

thanks
I will try logging in as Malcanis to see what happens. Is he still where the problem occurs?

I just fixed an uninitialized variable in a ringworld shader. Have you tried the latest client update?
Logged back in today and brought Malcanis back to problem system, CDT as soon as I entered orbit of ringworld arc.
I know you are actively working on this one so here is an update on what I'm seeing on my end.

I logged thru all 5 of my characters to do a maintenance run thru all their systems. Every time I came out of a transition to another system or character I got ctd'd. This occurred with all 5 characters. Logging back in allowed me to interact with the system with no issues.
When I switch to some of your avatars, my client program does not crash but it does print out some OpenGL errors. Depending on how your video driver handles the error situation, it could result in a crash.

I am searching for the cause of those errors. I'll post a client update as soon as they are fixed so you can test.
Pages: 1 2 3